Mac OS X Lion में स्थान सेवाएँ हमेशा अक्षम होती हैं


2

एक साधारण स्थान सेवा कार्यक्रम मेरी मशीन पर ठीक काम कर रहा था और अचानक काम करना बंद कर दिया। समस्या की और खोज करने पर, मुझे महसूस हुआ कि कुछ प्रक्रियाओं में सिस्टम वरीयताएँ »सुरक्षा और गोपनीयता» गोपनीयता में स्थान सेवाएँ अक्षम हैं ।

मैंने Enable Location Services की जाँच की , लेकिन फिर से यह स्वचालित रूप से अक्षम हो गया।

कुछ शोध के बाद मैंने पाया कि यह सिर्फ मेरा कार्यक्रम नहीं है, यहां तक ​​कि अंतर्निहित सिस्टम फ़ंक्शन भी इस समस्या के कारण विफल हो रहे हैं उदाहरण के लिए सिस्टम वरीयताएँ »दिनांक और समय» समय क्षेत्र वर्तमान स्थान प्राप्त करने में विफल रहा।

हर बार जब मैं स्थान सेवाओं को सक्षम करता हूं , तो मुझे कंसोल लॉग में निम्न त्रुटि दिखाई देती है:

16/10/12 11:23:15.636 AM [0x0-0x42042].com.apple.systempreferences: ERROR,Time,372059595.636,Function,"CLInternalSetLocationServicesEnabled",CLInternalSetLocationServicesEnabled failed
16/10/12 11:23:15.638 AM [0x0-0x42042].com.apple.systempreferences: STACK,Time,372059595.636,1   CoreLocation                        0x00007fff8f9957be CLInternalSetLocationServicesEnabled + 110

टिप्पणियाँ:

  • वाईफाई चालू है
  • मैंने iOS सिम्युलेटर स्थापित नहीं किया है
  • मैं Xcode संस्करण 4.5 (4G182) का उपयोग करता हूं
  • मैं बूट कैंप का उपयोग करता हूं और अपना मैकबुक प्रो डुअल बूट (मैक ओएस एक्स लायन और विंडोज 7) बनाया है
  • मैं केवल मैक डेवलपमेंट करता हूं लेकिन iOS नहीं

जवाबों:


1
#!/bin/sh
launchctl unload /System/Library/LaunchDaemons/com.apple.locationd.plist

defaults write /System/Library/LaunchDaemons/com.apple.locationd Disabled -bool false 

then

launchctl load /System/Library/LaunchDaemons/com.apple.locationd.plist

exit 0

5
मुझे लगता है कि आपका उत्तर थोड़ा स्पष्टीकरण और उचित प्रारूपण से लाभान्वित होगा।
सामी लाईन

हालांकि यह प्रश्न का उत्तर दे सकता है, यह एक बेहतर उत्तर होगा यदि आप कुछ स्पष्टीकरण प्रदान कर सकते हैं कि ऐसा क्यों होता है।
DavidPostill

यह उत्तर वास्तव में मेरे लिए समस्या को व्यक्तिगत रूप से हल नहीं करता है (मैंने इसे केवल कोड स्वरूपण जोड़ने के लिए अद्यतन किया है)। यह समस्या मेरे लिए हल हो गई है, जो समाधान मैंने अपने प्रस्तुत जवाब में नोट किया है।
जॉन एल।

0

मैं OSX 10.11 (El Capitan) में इसी मुद्दे का सामना कर रहा हूं।

मुझे यह पोस्ट ( https://jamfnation.jamfsoftware.com/discussion.html?id=5336#responseChild65097 ) मिली । मैंने स्क्रिप्ट को भीतर चलाया, और अंत में मेरी स्थान सेवाएँ तय की गईं।

#!/bin/bash

########################## SET SYSTEM TIME  ##################################################
#
# Written by Tim Kimpton
#
# using information from https://jamfnation.jamfsoftware.com/discussion.html?id=5336
#
# If the machine is 5 minutes out of the kdc the machine will not bind to the domain.
#
# This script does the folling to ensure the time is correct
#
# 1. Unload the launch daemon used for location services
#
# 2. Get the hardware UUID of the machine and put it in the location services db
#
# 3. Enable location services
#
# 4. Correct permissions on the database file used for location services
#
# 5. Set the time zone to update the time automatically
#
# 6. Set the network time to on
#
# For information see https://jamfnation.jamfsoftware.com/discussion.html?id=5336
###############################################################################################

######################### ENVIRONMENT VARIABLES #######################

# Get the Hardware UUID from system profiler
uuid=$(/usr/sbin/system_profiler SPHardwareDataType | grep "Hardware UUID" | cut -c22-57)

####################### DO NOT MODIFY BELOW THIS LINE #################

# Unload the launch daemon
/bin/launchctl unload /System/Library/LaunchDaemons/com.apple.locationd.plist

# Write the UUID to the hidden plist file and initialise it
/usr/bin/defaults write /var/db/locationd/Library/Preferences/ByHost/com.apple.locationd."$uuid" LocationServicesEnabled -int 1

# Enable Location Services
/usr/bin/defaults write /var/db/locationd/Library/Preferences/ByHost/com.apple.locationd.notbackedup."$uuid" LocationServicesEnabled -int 1

# Make sure the permissions on the database file is correct
/usr/sbin/chown -R _locationd:_locationd /var/db/locationd
/bin/launchctl load /System/Library/LaunchDaemons/com.apple.locationd.plist

# Set time zone to update automatically
/usr/bin/defaults write /Library/Preferences/com.apple.timezone.auto Active -bool true

# Set network time to on
/usr/sbin/systemsetup -setusingnetworktime on > /dev/null 2>&1

exit 0

टिम किम्प्टन की पटकथा अगर सुपरसुसर के रूप में चलती है तो काम करती है। इनमें से किसी भी शेल कमांड को चलाने से पहले अपने आप को शेल में पहले रूट या सुपरयुसर बनाएं। मेरी स्थान सेवाएँ अब सक्षम हैं।
हमारी साइट का प्रयोग करके, आप स्वीकार करते हैं कि आपने हमारी Cookie Policy और निजता नीति को पढ़ और समझा लिया है।
Licensed under cc by-sa 3.0 with attribution required.